Recent Posts

Pages: [1] 2 3 ... 10
1
Support Questions / Re: chart and database
« Last post by oqapsking on Today at 03:00:13 AM »
can any one help me ?

how to make a database and use it with ahmi ?

2
Support Questions / Re: chart and database
« Last post by oqapsking on April 29, 2017, 10:29:17 PM »
and the code he uses is not vb net

and i am a noop
3
Support Questions / Re: chart and database
« Last post by oqapsking on April 29, 2017, 10:26:54 PM »
yes it is but i didn`t see how he made the database file
4
Support Questions / Re: chart and database
« Last post by Godra on April 29, 2017, 09:51:06 PM »
5
Support Questions / chart and database
« Last post by oqapsking on April 29, 2017, 09:26:07 PM »
hello

there was a video about making a chart and connect it to database and i cant find it

what i need to do
say i have a basiclabel reads some register

and i want to store the values on database file and display them in chart

in the chart i can choose the from date to date  and time to time

by the way i dont have experience in database usage

with thanks

6
Support Questions / Re: The Given Key Not Found
« Last post by needhmi on April 29, 2017, 06:05:35 PM »
That is easy and works great.  Sorry I did not read that post before. 
7
Support Questions / Re: The Given Key Not Found
« Last post by Archie on April 29, 2017, 05:26:01 PM »
Do not use publish or an installer. See this:

http://advancedhmi.com/forum/index.php?topic=14.msg37#msg37

The required .NET framework is full 4.0 (not Client profile). If you run all Windows updates it will install the necessary components.
8
Support Questions / The Given Key Not Found
« Last post by needhmi on April 29, 2017, 05:13:47 PM »
My application runs fine in debug mode, with no errors - but after I have it published and installed on different computers the message "The Given Key Not Found in Dictionary" shows up on most of my "Value" or "Text" properties on my mainform.vb. 

I'm assuming I am missing some sort of dependency on the computers I have installed it on.  I found the "Prerequisites" tab in the Advanced HMI Properties section and a couple prerequisites that are not checked have flags:

.NET Framework 3.5 SP1 Client Profile

Windows Installer 3.1

Thanks for any ideas!  I'm really new to this stuff. 

9
Additional Components / Re: ImageSelectByBit that supports animation
« Last post by oqapsking on April 29, 2017, 03:15:29 PM »
one note

i inserted ImageSelectByBitHMI1 then i choosed the off picture and the on picture
then i choosed the plcvalue address

now when i run the project it works great

but if i copy  ImageSelectByBitHMI1 and paste it because i need more than one
and changed the plcvalue addresses
i run the project and they work but the onpicture does not animate so i choose it again for each copy

after that everything is good

why do you think every copy i make  i have to re-choose the animated picture ?



10
Support Questions / Re: making my own class ImageDisplayByValue
« Last post by oqapsking on April 29, 2017, 03:08:40 PM »
thanks man
it worked great
Pages: [1] 2 3 ... 10